Archieven

grafieken

Percentages bij gecumuleerde kolomgrafiek

V. Kan ik procentuele waarden zetten bij een 100 %-gecumuleerde grafiek in Excel?

A. Neen – als je gegevenslabels toevoegt, geeft Excel de waarden.

Wat je wel kan doen, is het procentueel aandeel van elk deeltje berekenen

en daar een grafiek van maken.

Lastig? bekijk mijn voorbeeld

Voorwaardelijke opmaak van een grafiek

Heb je al eens geprobeerd om een grafiek voorwaardelijk op te maken?

Het is niet echt moeilijk. Even tonen:

  • Wat we hier beschrijven gaat alleen met kolommen.
  • Plaats op een eerste blad de waarden.
  • Op een tweede blad neem je die waarden over in de eerste kolom. Je plaats ergens de minimumwaarde (de waarde waaronder je een bepaalde opmaak wil) en de maximumwaarde (de waarde waarboven je een andere opmaak wil).
  • Nu de magie:
  • In de tweede kolom laat je de waarde verschijnen als ze onder het mininum is.
    =ALS(A2<$H$1;A2;0)
  • In de derde kolom laat je de waarde verschijnen als ze boven het maximum is.
    =ALS(A2>$H$2;A2;0)
  • In de vierde kolom laat je de waarde verschijnen als ze tussen minimum en maximum is.
    =A2-(B2+C2)
  • En dan maak je een kolomgrafiek met kolommen van verschillende kleuren.

Werkend voorbeeld in bijlage

Rasterlijnen verwijderen uit grafiek

V. Hoe kan ik rasterlijnen verwijderen uit een grafiek?

A. Probeer rechtsklikken, dan verwijderen. Anders: rechtsklik op de Y as, en stel de rasterlijnen in als wit.

Enquêtes verwerken: reeksen van antwoorden

Soms gaat een reeks van antwoorden gebruikt worden voor verschillende vragen. Dat is bv. het geval met waardeschalen. De eenvoudigste manier om die te verwerken, is tellen met AANTAL.ALS.

Nadeel is dat je geen draaitabellen kan gebruiken om antwoorden op verschillende vragen te combineren. Dat is op te lossen door de antwoorden op twee vragen te combineren met &:

en die te tellen met AANTAL.ALS waarbij je het criterium van AANTAL.ALS ook samenvoegt met &:

Antwoorden op enquêtes omzetten in cijfers en grafieken

V. Ik heb een aantal antwoorden op een set van vragen. Hoe krijg ik daar grafieken uit?

A. Zo kan je dat doen:

Nieuwe grafieken in Excel 2016

V. Ik heb pas Excel 2016 in gebruik genomen en ik heb de indruk dat er iets veranderd is aan de soorten grafieken.
A. Ja, er zijn zes grafieksoorten bijgekomen. Bijvoorbeeld:

Er is een overzicht op

Grafiek maken voor zwart/wit afdrukken

V. Ik heb grafieken in een tekst opgenomen die gekopieerd is, maar die grafieken zijn niet te te lezen. Is dat op te lossen?

A. Je kan een grafiek voorbereiden voor gebruik in zwart/wit afdrukken.

Het was eenvoudiger in Excel 2010. Zie https://www.ablebits.com/office-addins-blog/2012/03/28/excel-charts-tips/

In Excel 2013 en 2016 doe je dat zo.

  • Maak de grafiek
  • Rechtsklik op een regio / segment en kies Opvulling, Bitmappatronen, Meer bitmappatronen. Kies rechts voor Patroonopvulling
     
  • TIP. In het geval van cirkelgrafieken, zorg ervoor dat de labels duidelijk vermeld zijn. Voeg Gegevenslabels toe (via +), kies rechts voor Categorienaam en Labellijnen toevoegen

 

 

 

Voorwaardelijke opmaak van een grafiek

V. Ik weet hoe ik voorwaardelijke opmaak van cellen kan doen in Excel. Maar kan ik dat ook doen met grafieken?

A. Ja, dat kan. Het mees voor de hand liggend zijn kolommen – en de oplossing is het maken van een gestapelde kolommen. Bijvoorbeeld door het uitlichten van minimum en maximum, of het laten aanduiden van waarden onder een bepaalde waarde en boven een andere bepaalde waarde.

 

Dat gaat zo: een kolom met de waarden die in de grafiek moeten worden opgenomen, een kolom (of enkele kolommen) met de waarde die moet worden uitgelicht, en een kolom met de restwaarde.

Bijvoorbeeld: minimum en maximum uitlichten.

  • een kolom met de waarden
  • een kolom voor het minimum
    =ALS(A2=MIN(A:A);MIN(A:A);0)
  • een kolom voor het maximum
    =ALS(A2=MAX(A:A);MAX(A2);0)
  • en een kolom met de restwaarde voor de grafiek – als er geen minimum of maximum is
    =A2-(B2+C2)
  • dat ziet er zo uit – en dan maak je een gestapelde kolomgrafiek

Bijvoorbeeld: het laten markeren van waarden onder een bepaalde waarde, en andere boven een bepaalde waarde.

  • een kolom met de waarden
  • een plaats waar de minimumgrens staat en een waar de maximumgrens staat
  • een kolom met de waarden onder de ondergrens
    =ALS(A2<$H$1;A2;0)
  • een kolom met de waarden boven de bovengrens
    =ALS(A2>$H$2;A2;0)
  • en een kolom met de restwaarde voor de grafiek – de waarden tussen de ondergrens en de bovengrens
    =A2-(B2+C2)

Interesse? Dit is het uitgewerkte voorbeeld, met randomgetallen voor de waarden.

Meer weten?

 

Trendlijn met volle lijn

V. Als ik een trendlijn toevoeg aan een grafiek in Excel krijg ik een stippellijn. Kan ik daar geen volle lijn van maken?

A. Jawel.

  • Voeg een trendlijn toe aan de grafiek vie +, Trendlijn. Kies voor “Meer opties”
  • Ga naar Type streepje en kies naar de lijn die je wil gebruiken

    Je
    kan zo overigens ook een pijl toevoegen, als je dat zou willen.

In Excel kaarten maken met regionale verdeling van gegevens

Je kan met behulp van Excel een grafische voorstelling maken van gegevens.

Twee reeksen metingen samenvoegen

V. Ik heb twee reeksen metingen – telkens met een uur en een gemeten waarde. Hoe kan ik daarvan één grafiek maken?

meting-a meting-b

A. Plak de metingen op ene nieuw blad – de tijden onder elkaar, meting A in een tweede kolom, en meting B in een derde kolom (tenzij je weet dat de metingen mogen samengevoegd worden).

meting-ab

Sorteer op moment, en werk van daar verder.

Interactieve grafiek maken

V. Hoe kan ik ene interactieve grafiek maken voor gebruik in mijn website of blog?

A. Je kan het bijvoorbeeld doen met Google Drive.

  1. Log in in Google drive (nest met Firefox als je wil verlijden dat Google blijft zagen om het gevaarlijke Chrome te installeren).
  2. Maak een Google spreadsheet. Geef je gegevens in, doe de nodige berekeningen en maak de grafiek.
  3. In de grafiek, klik op de pijl naar beneden links van het oog (dat toegang geeft tot “Weergavemodus”) en kies “Diagram publiceren”.
    googlecalc-interactivechart
  4. Bij de instellingen kan je bv. bepalen:
    googlecalc-interactivechart2

    • of je een link wil dan wel invoegen
    • of die link / inbedding alles is of die ene pagina
    • of je een afbeelding wil dan wel een interactief element
  5. En dat ziet er zo uit
    googlecalc-interactivechart4
  6. De embed code geeft de grafiek in interactieve vorm – inclusief latere updates van de gegevens.Dit is het resultaat:

 

 

 

Excel 2016 kan prognoses maken

Een leuke nieuwigheid in Excel 2016: de nieuwste versie kan automatische prognoses maken op een apart blad. Het ziet er zo uit:

Details staan uitgelegd in Een prognose maken in Excel 2016 voor Windows – https://support.office.com/nl-be/article/Een-prognose-maken-in-Excel-2016-voor-Windows-22c500da-6da7-45e5-bfdc-60a7062329fd

Het komt hierop neer: selecteer de bekende gegevens, Gegevens, Prognoseblad, begin en einde opgeven.

Nog geen Excel 2016? Geen nood – in 2013 kan er ook zo iets, maar dan heel rudimentair. Selecteer de gegevens, maak een grafiek en voeg een trendlijn toe. Bij de opties voor die trendlijn kies je Voorspelling en stelt in voor hoeveel stappen / periodes.

xl2013-voorspellingen

 

Grafiek met data werkt niet goed

V. Ik heb hier een logfile met data in de eerste kolom. Die data zijn niet volledig (omdat de server af staat, bijvoorbeeld). Maar als ik daar in Excel een grafiek van maak, krijg ik een vreemd resultaat.

A. Vier dingen:

  • Zorg dat de data wel degelijk data zijn, en geen strings
  • Sorteer de data in chronologische volgorde
  • Zorg dat er geen 0 (nul) of “” (lege string) staat in cellen die leeg behoren te zijn.
  • Maak een spreidings diagram of scatter

Voortgangsbalk in Excel

V. Hoe kan ik makkelijk een voortgangsbalk maken in Excel?

A. Met de gegevensbalken onder voorwaardelijke opmaak.

  1. Zet ergens je gegeven. Voorwaardelijke opmaak, gegevensbalken.
  2. Voorwaardelijke opmaak, Regels beheren, Regel bewerken
    xlprogress1
  3. Afhankelijk van wat je wil: Minimum GETAL (of PROCENT) en bv.0, Maximum GETAL (of PROCENT en bv. 100.
    xlprogress2

Zie ook: http://www.tech-recipes.com/rx/35064/excel-2013-create-progress-bars/

ip-location